API Hub Bank Statement EU Service Issue

Started
Lasted 33min
MAJOR

Updates

RESOLVED

lasted 33min

The incident has been resolved

INVESTIGATING

33min earlier

The API Hub bank statement extraction service in the EU region is not responding to health checks.